Progetti

   

Tutorial

   

Servizi

   
Benvenuto, Ospite
Nome utente: Password: Ricordami

ARGOMENTO: Picchi di tensione

Picchi di tensione 5 Anni 1 Mese fa #51

  • FABRIZIO
  • Avatar di FABRIZIO
  • Offline
  • Gold Boarder
  • Messaggi: 188
  • Karma: 0
Ciao a tutti. Continuo ad avere il problema del reset del pic quando al mio circuito d'allarme, dopo che è mancata tensione o per scatto dell'interrutore generale o per mancanza da fuori, ritornando e solo ritornando mi si resetta e si reinizializza il programma. Gli altri problemi, ossia l'inchiodamento del programma dopo un'azione del tipo usare un trapano, gli ho risolti collegando a monte dell'alimentazione 220 volt un filtro di rete monofase per inverter. Non capisco cosa vede, potrebbe darsi che per un attimo entrano più di 5 volt sul pic? Boh, non so che fare! :(
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Picchi di tensione 5 Anni 1 Mese fa #52

  • +RGZ
  • Avatar di +RGZ
  • Offline
  • Junior Boarder
  • Messaggi: 22
  • Karma: 0
Ciao a tutti, Lo schema è sempre quello di pagina 3 ? I pedini di I/O del micro che non hai utilizzato come li hai configurati ? Li hai lasciati flottanti? Ciao Gabriele
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Picchi di tensione 5 Anni 1 Mese fa #53

  • FABRIZIO
  • Avatar di FABRIZIO
  • Offline
  • Gold Boarder
  • Messaggi: 188
  • Karma: 0
Coa Gabriele se non vado errato li ho configurati come entrate, perchè potrebbe centrare qualcosa col mio problema? Sì è sempre quello schema lì, un po' incomprensibile lo ammetto...
Grazie
Ciao
Fabrizio
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Picchi di tensione 5 Anni 1 Mese fa #54

  • +RGZ
  • Avatar di +RGZ
  • Offline
  • Junior Boarder
  • Messaggi: 22
  • Karma: 0
Secondo me il micro può resettarsi non solo se il disturbo entra attraverso l'alimentazione, ma anche se entra attraverso un ingresso analogico o digitale soprattutto se la resistenza di ingresso è alta, ho avuto problemi simili anche io con una centralina che pilotava motori ed elettrovalvole 220Vac e mi ricordo che il disturbo entrava proprio dai canali analogici che in quel caso leggevano le temperature. Non so se sia il caso tuo, puoi limitare la tensione sugli ingressi usati con uno zener da 5V ad esempio e mettere a massa quelli che non usi. Il problema si presenta ad ogni accensione oppure è ogni tanto si ogni tanto no? Spero di esserti stato di aiuto Ciao Gabriele.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Picchi di tensione 5 Anni 1 Mese fa #55

  • FABRIZIO
  • Avatar di FABRIZIO
  • Offline
  • Gold Boarder
  • Messaggi: 188
  • Karma: 0
Cero che mi sei d'aiuto, il problema non persiste tutte le volte che manca tensione, ma quasi. Ho solamente una porta libera. Proverò, grazie
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
Moderatori: Mauro Laurenti, StefA, doc83
Powered by Forum Kunena
   
© LaurTec 2006-2015