Progetti

   

Tutorial

   

Servizi

   
Benvenuto, Ospite
Nome utente: Password: Ricordami

ARGOMENTO: Pagina HTML

Pagina HTML 3 Anni 5 Mesi fa #1

  • elpablito
  • Avatar di elpablito
  • Offline
  • Platinum Boarder
  • Messaggi: 329
  • Ringraziamenti ricevuti 7
  • Karma: 2
Buon giorno
Sto scrivendo in con un altro linguaggio una pagina web che il server dovrebbe inviare a chi lo chiama.
Dopo aver letto il solito manuale su come fare la pagina ed esempi vari sono giunto al codice riportato sotto
Va tutto bene fino al <body> ove sono fermo su un errore che non sono in grado di risolvere. Sarebbe graditissima la risposta da qualcuno più esperto del sottoscritto.

<h1 ALIGN=CENTER>ESP8266 CAR CONTROL</h1> visualizza correttamente la strina ESP8266 CAR CONTROL
<a href=\"/?pin=ON1\"> <button style=\..................... visualizza correttamente il button AVANTI
<a href=\"/?pin=ON2\"> <button style=\...................... NON visualizza è come se la riga non fosse scritta, dovrebbe far comparire un button simile al precedente sulla stessa riga con titolo INDIETRO.

E' un problema di come concatenare le due stringhe, ma non ci riesco.

"<html>\
<head>\
<meta http-equiv='refresh' content='5'/>\
<title> ESP8266 Car Control </title>\
<style>\
body { background-color: #cccccc; font-family: Arial, Helvetica, Sans-Serif; Color: #000088; }\
</style>\
</head>\
<body>\
<h1 ALIGN=CENTER>ESP8266 CAR CONTROL</h1>\
<a href=\"/?pin=ON1\"> <button style=\"width:200px;height:70px\"> <font size=\"6\">AVANTI </font> </button> </a>\
<a href=\"/?pin=ON2\"> <button style=\"width:200px;height:70px\"> <font size=\"6\">INDIETRO </font> </button> </a> <br/><br/>\
</body>\
</html>"

Saluti
Paolo
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Pagina HTML 3 Anni 5 Mesi fa #2

  • elpablito
  • Avatar di elpablito
  • Offline
  • Platinum Boarder
  • Messaggi: 329
  • Ringraziamenti ricevuti 7
  • Karma: 2
ho scoperto la magagna. Il codice è sintatticamente corretto era il buffer che doveva contenerlo che era troppo piccolo e quindi ne mancava un pezzo
ringrazio e saluto
Paolo
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Pagina HTML 3 Anni 5 Mesi fa #3

  • Mauro Laurenti
  • Avatar di Mauro Laurenti
  • Offline
  • Moderatore
  • Messaggi: 4486
  • Ringraziamenti ricevuti 516
  • Karma: 49
...bene, hai risolto da solo! :)

Quale dimensione del buffer hai cambiato?
Della stringa che contiene il messaggio HTML?

Saluti,

Mauro
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Pagina HTML 3 Anni 5 Mesi fa #4

  • elpablito
  • Avatar di elpablito
  • Offline
  • Platinum Boarder
  • Messaggi: 329
  • Ringraziamenti ricevuti 7
  • Karma: 2
proprio quella.
Saluti
Paolo
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
Moderatori: Mauro Laurenti, StefA, doc83
Powered by Forum Kunena
   
© LaurTec 2006-2015