Progetti

   

Tutorial

   

Servizi

   

Sponsor  

   
Benvenuto, Ospite
Nome utente: Password: Ricordami

ARGOMENTO: SIM900 e PIC

SIM900 e PIC_GSM.X 4 Anni 9 Mesi fa #46

  • fer_ver
  • Avatar di fer_ver
  • Offline
  • Expert Boarder
  • Messaggi: 91
  • Ringraziamenti ricevuti 11
  • Karma: 2
Ciao,
non conosco bene hyper ma il fatto che con Ctrl+Z cancelli l'ultimo carattere mi fa pensare che hyper non sia impostato per trasmettere un singolo carattere per volta bensì per inviare la stringa completa.
Ctrlz+Z nei PC annulla l'ultimo comando inviato, nel tuo caso l'ultimo carattere immesso.
Come detto non conosco bene hyper, ho sempre usato RS232 terminal, che trovi su questo sito.
Comunque, a mio giudizio, prima di tutto devi riuscire ad inviare i comandi tra PC e SIM...dopo potrai provare tra PIC e SIM.
Penso che tutte queste esperienze che ti ritrovi a fare, dovrebbero stimolarti ad imparare a far pratica con il debug dei programmi, che reputo una cosa fondamentale.
Buon proseguimento, e insisti che sicuramente riuscirai a risolvere...comunque non esitare a chiedere,
per quel che posso, cercherò di aiutarti.
Renato
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

SIM900 e PIC 4 Anni 9 Mesi fa #47

  • Mauro Laurenti
  • Avatar di Mauro Laurenti
  • Offline
  • Moderatore
  • Messaggi: 4677
  • Ringraziamenti ricevuti 561
  • Karma: 52
Riporto il Link di RS232 Terminal.

Saluti,

Mauro
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

SIM900 e PIC 4 Anni 9 Mesi fa #48

  • GYL
  • Avatar di GYL
  • Offline
  • Fresh Boarder
  • Messaggi: 6
  • Karma: 0
Ciao grazie ragazzi.
ho risolto il programma non girava bene a causa delle impostazioni nel modulo gsm.
AT+CNMI il mio modulo era impostato con valori 2,2,0,0,0 quindi non salvava i messaggi ma li visualizzava direttamente! quindi ho iniziato a smanettare sul programma per adattarlo a questo tipo di messaggio ignorando che avrei potuto impostarlo 1,1,0,0,0. Tutto questo usando RS232 terminal di Laurenti(usavo quello ho detto hyper per sbaglio). Mettendo in ordine quel dato tutto ok pero rimaneva il problema del ctrlZ quindi ho abilitato i messaggi estesi con AT+CMEE=1 e poi con 2, e con il relativo errore 515 o ps busy ho navigato in siti di ogni lingua e zero assoluto. Qualcuno parlava su un forum di credito e cose del genere insomma il credito c'era. Quindi ho provato a cambiare sim e mettendo la mia che è una 4g (non so cosa possa cambiare visto che il sim900 è 2g) tutto funziona magnificamente (in questo caso e tornato a funzionare ctrlZ). Spero che questa mia esperienza possa servire a qualcuno.
Ciao grazie
Ultima modifica: 4 Anni 9 Mesi fa da GYL.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

SIM900 e PIC 4 Anni 9 Mesi fa #49

  • fer_ver
  • Avatar di fer_ver
  • Offline
  • Expert Boarder
  • Messaggi: 91
  • Ringraziamenti ricevuti 11
  • Karma: 2
Ciao,
sono contento che hai risolto B) ,
questi moduli GSM hanno una marea di comandi e relativi modi di funzionare.
Ora vado a "curiosare" un po' i due comandi AT che hai utilizzato e menzionato.

Saluti,
Renato
Ultima modifica: 4 Anni 9 Mesi fa da fer_ver.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

SIM900 e PIC 4 Anni 9 Mesi fa #50

  • GYL
  • Avatar di GYL
  • Offline
  • Fresh Boarder
  • Messaggi: 6
  • Karma: 0
Ciao
Per caso sai indicarmi una guida su come fare il debug con pickit3 ed mplabx o solo con mplab??
A presto thanks
Ultima modifica: 4 Anni 9 Mesi fa da GYL.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
Moderatori: Mauro Laurenti
Powered by Forum Kunena
   
© LaurTec 2006-2015