Progetti

   

Tutorial

   

Servizi

   
Benvenuto, Ospite
Nome utente: Password: Ricordami

ARGOMENTO: SIM900 e PIC

SIM900 e PIC 10 Anni 10 Mesi fa #1

  • davix10
  • Avatar di davix10
  • Offline
  • Senior Boarder
  • Messaggi: 41
  • Karma: 0
Salve a tutti, ho da poco acquistato questo modulo gsm: 8100-TDGGSM_900 da futura elettronica. Volevo sapere se alimentando il modulo e inserendo la sim e provando a chiamare il numero di telefono dovrei sentire squillare oppure come se fosse spento.
Se avete anche qualche link da darmi al riguardo sarei molto felice dato che sono alle prime armi.
Grazie in anticipo.
Davide
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Re: SIM900 e PIC 10 Anni 10 Mesi fa #2

  • Gianni
  • Avatar di Gianni
  • Offline
  • Gold Boarder
  • Messaggi: 214
  • Ringraziamenti ricevuti 11
  • Karma: 7
La prima cosa da fare: disabilita il pin sulla sim che vai ad inserire nel modulo, almeno per facilitarti all'inizio.
Dopo aver inserito la sim e dato corrente, aspetta che si registri alla rete. In genere tutti i moduli avvisano dell'avvenuta registrazione con un impulso su una linea di interrupt dedicata o scrivendo un messaggio su seriale, tipo "ready"

Dopo di ciò, la chiamata AUDIO si fa con:

ATD<numero>;

e premi invio (non devi mettere le <> ... ) Non devi tralasciare il punto e virgola alla fine altrimenti la chiamata viene eseguita come chiamata dati (sui cellulari nokia compare proprio "chiamata dati")

Il telefono chiamato mi pare ovvio che squilla.
Sono tutti bravi ad essere "open" con il "source" degli altri.
Un amico è colui che ti dice sempre quando stai sbagliando. Il mio miglior amico è il parser.
SettoreZero
Ultima modifica: 10 Anni 10 Mesi fa da Gianni.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Re: SIM900 e PIC 10 Anni 10 Mesi fa #3

  • davix10
  • Avatar di davix10
  • Offline
  • Senior Boarder
  • Messaggi: 41
  • Karma: 0
Ho collegato come hai detto ma sulla seriale non leggo nulla e contattando futura elettronica mi hanno detto che il pin ON/OFF deve essere mandato a livello logico alto per circa 2-3 secondi ma, facendo in questo modo il sistema risulta essere sempre spento appena rilascio il pulsante dopo aver aspettato 2 o 3 secondi.
Come posso fare? non sono presenti nemmeno delle istruzioni
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Re: SIM900 e PIC 10 Anni 10 Mesi fa #4

  • Gianni
  • Avatar di Gianni
  • Offline
  • Gold Boarder
  • Messaggi: 214
  • Ringraziamenti ricevuti 11
  • Karma: 7
Si, dimenticavo.
Tutti i moduli GSM hanno un pin per l'ignition, cioè hanno bisogno di una sequenza particolare per l'avvio. Ogni modulo ha il suo sistema.

Sul mio blog in inglese ho pubblicato qui un circuito che vale per il TC35 della siemens: settorezero.blogspot.com/2010/11/modem-s...s-tc35-ignition.html
devi vedere quale chip monta il tuo modulo e vedere sul datasheet preciso cosa vuole.
Sono tutti bravi ad essere "open" con il "source" degli altri.
Un amico è colui che ti dice sempre quando stai sbagliando. Il mio miglior amico è il parser.
SettoreZero
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Re: SIM900 e PIC 10 Anni 10 Mesi fa #5

  • davix10
  • Avatar di davix10
  • Offline
  • Senior Boarder
  • Messaggi: 41
  • Karma: 0
Ma devo guardare sul datasheet del modulo SIM900?
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
Moderatori: Mauro Laurenti
Powered by Forum Kunena
   
© LaurTec 2006-2022