Arduino Mega 2560 non si installa

7 Anni 1 Mese fa #1 da Guido
Arduino Mega 2560 non si installa è stato creato da Guido

Rendering Error in layout Message/Item: array_keys(): Argument #1 ($array) must be of type array, null given. Please enable debug mode for more information.

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • Guido
  • Platinum Member
  • Platinum Member
Di più
7 Anni 1 Mese fa #2 da Cosimix
Risposta da Cosimix al topic Arduino Mega 2560 non si installa
Salve!

Tempo fa riscontrai un problema simile con un clone di Arduino UNO, però non ricordo bene il messaggio di errore.
Hai installato i driver FTDI? Scarica dal seguente link quelli relativi al tuo sistema operativo:

www.ftdichip.com/Drivers/VCP.htm

Prova ad eliminare l'attuale periferica da gestione dispositivi, installa i driver e dopo collega la scheda.

Saluti,
Cosimo

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • Cosimix
  • Avatar di Cosimix
  • Elite Member
  • Elite Member
Di più
7 Anni 1 Mese fa #3 da Guido
Risposta da Guido al topic Arduino Mega 2560 non si installa
Ciao e grazie, non sapendo l'iglese devo scaricare i driver dalla voce Windows/Comments/WHQL Certified. Includes VCP and D2XX.
Available as a setup executable/CDM2122LSetup.exe ?
Dato che è un eseguibile non vorrei fare dei casini.
Grazie ancora.

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • Guido
  • Platinum Member
  • Platinum Member
Di più
7 Anni 1 Mese fa #4 da Guido
Risposta da Guido al topic Arduino Mega 2560 non si installa
Ciao grazie per i consigli (tramite traduttore e poco inglese scolastico), sono riuscito ad installare i driver seguendo la guida:
www.ftdichip.com/Support/Documents/AppNo...ide_for_Windows7.pdf

Ora in Gestione dispositivi/Porte (COM e LPT) non compare il nome della scheda Arduino Mega 2560 ma USB Serial Port (COM7). Se ci clicco sopra mi dice: Il dispositivo funziona correttamente.
Apro il programma Arduino 1.8.1 setto la porta per la COM7, avvio il programma Blink ed ottengo la scritta in rosso:
avrdude:ser_send0 write error: sorry no info avail.
per cortesia hai altri suggerimenti.
Grazie Guido

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • Guido
  • Platinum Member
  • Platinum Member
Di più
7 Anni 1 Mese fa #5 da Cosimix
Risposta da Cosimix al topic Arduino Mega 2560 non si installa
Salve!

Sì, devi scaricare quelli relativi all'architettura del tuo processore (32bit o 64bit).

Una curiosità: utilizzi per caso un HUB USB?
Se sì, rimuovilo e prova a collegare direttamente la scheda alla porta USB del PC.
Prova a scollegare anche tutte le altre periferiche USB connesse (tranne quelle indispensabili ovviamente, tipo mouse e tastiera) e a cambiare porta.

Saluti,
Cosimo

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • Cosimix
  • Avatar di Cosimix
  • Elite Member
  • Elite Member
Di più
Moderatori: Mauro Laurenti

Registrati al sito

Accedi a tutte le risorse e articoli non visibili pubblicamente, puoi registrarti con pochi passi.

Registrati al sito LaurTec.

Login