Problema UART1 su PIC24FJ128GA010 microchip

9 Anni 3 Settimane fa #1 da mastro86
Problema UART1 su PIC24FJ128GA010 microchip è stato creato da mastro86
Salve a tutti,

Sto lavorando con il PIC24fj128ga010 e con il modulo wireless ES8266EX (marca: Espressif).

Il PIC deve inviare stringhe di comando al modulo wi-fi tramite la porta Uart1 e deve aspettare le risposte degli esiti del comando da parte del modulo.

Ho effettuato il debug sia del PIC collegato al PC tramite convertitore FTDI, che del modulo wi-fi collegato al PC; in modo che una prima volta ho emulato il PIC che invia comandi al modulo wi-fi e una seconda volta il modulo wi-fi che invia le risposte al PIC.

In entrambi i casi la comunicazione con il PC va a buon fine. Quando collego il modulo wi-fi tramite la porta UART1 del PIC, i due sistemi insieme non funzionano (entrambi impostati con i parametri della seriale 9600, 8, n, 1).
Quale potrebbe essere il problema?
Grazie a tutti.

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • mastro86
  • New Member
  • New Member
Di più
9 Anni 2 Settimane fa #2 da Mauro Laurenti
Risposta da Mauro Laurenti al topic Problema UART1 su PIC24FJ128GA010 microchip
La cosa sembra strana visto ch le singole parti sembrano funzionare.
Quello che mi viene in mente e' di accertati che il livelli logici siano corretti, e che le linee TX e RX siano collegate in maniera corretta.

Se il PIC24 riesce a comunicare con il PC vuol dire che le impostazioni sembrano corrette.

Se avessi un oscilloscopio per monitorare le linee TX e RX, sarebbe meglio.

Saluti,

Mauro

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • Mauro Laurenti
  • Avatar di Mauro Laurenti
  • Moderator
  • Moderator
Di più
Moderatori: Mauro LaurentiMatteo Garia

Registrati al sito

Accedi a tutte le risorse e articoli non visibili pubblicamente, puoi registrarti con pochi passi.

Registrati al sito LaurTec.

Login