La Peripheral Library non c'è

  • dami§*
  • Offline
  • Junior Member
  • Junior Member
Di più
6 Anni 4 Mesi fa - 6 Anni 4 Mesi fa #1 da dami§*
La Peripheral Library non c'è è stato creato da dami§*
Salve a tutti, ho un vecchio computer con installato linux (nuova versione) che uso per programmare.
Il vero problema è che ho solo la versione xc8 v1.37 in cui non esistono le librerie per le periferiche (usart, i2c, spi, ecc.) e non ho nessuna idea di dove trovarle, visto che ho già installato le MLA della microchip ma non ho trovato niente nemmeno li.
Qualcuno può aiutarmi?

Piccola curiosità:
Cercando se nel forum fosse già stata data soluzione al mio problema ho letto che la microchip avrebbe rimosso il supporto per le periferiche. Se così sarà come potremo continuare a sviluppare, per esempio, circuiti che necessitano di comunicare tra loro (anche le eeprom)? (Forse usando il modulo usb):huh:

Damiano
Ultima Modifica 6 Anni 4 Mesi fa da dami§*.

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • dami§*
  • Offline
  • Junior Member
  • Junior Member
Di più
6 Anni 4 Mesi fa #2 da dami§*
Risposta da dami§* al topic La Peripheral Library non c'è

Rendering Error in layout Message/Item: array_keys(): Argument #1 ($array) must be of type array, null given. Please enable debug mode for more information.

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • dami§*
  • Offline
  • Junior Member
  • Junior Member
Di più
6 Anni 4 Mesi fa #3 da dami§*
Risposta da dami§* al topic La Peripheral Library non c'è
Ho trovato il problema:
Il file i2c.h veniva messo nella riga di comando come input e non come file da includere.

Damiano

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
6 Anni 4 Mesi fa - 6 Anni 4 Mesi fa #4 da alfa75
Risposta da alfa75 al topic La Peripheral Library non c'è
Ciao dami

Da quello che ho capito hai gia letto la discussione dove si parlava appunto della fine del supporto delle plib da parte di microchip.

L'unica alternativa è usare le LTlib di Mauro che funzionano benissimo oppure usare il plugin di microchip, cioè MPLAB Code configurator che però a me personalmente non entusiasma.

Saluti,
Andrea
Ultima Modifica 6 Anni 4 Mesi fa da alfa75.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
6 Anni 4 Mesi fa #5 da Mauro Laurenti
Risposta da Mauro Laurenti al topic La Peripheral Library non c'è
Interessante la soluzione del problema.
Effettivamente credo che i test di integrazione non siano piu' fatti visto che il package plib e' ora separato.

Per questa ragione ed altre la nuova libreria LTlib integra ora anche le librerie a basso livello per i singoli moduli.

Puoi scaricare la libreria al seguente link .

Saluti,

Mauro

Si prega Accedi o Crea un account a partecipare alla conversazione.

Moderatori: Mauro Laurenti