Pickit 3 sembra non funzionare più...

  • manuelfantoni
  • Offline
  • New Member
  • New Member
Di più
5 Anni 8 Mesi fa #1 da manuelfantoni
Pickit 3 sembra non funzionare più... è stato creato da manuelfantoni
ciao a tutti,

su MPLAB vecchio (non X) non avevo problemi ad usare il Pickit 3. Sono passato ad MPLAB X e sono iniziati i problemi... non sono mai riuscito a far funzionare il Pickit 3...
Ho provato di tutto, cercato sui vari forum ecc ma in fase di programmazione il Pickit 3 restava come bloccato e dovevo buttare giù l'MPLAB X scollegare il Pickit 3.

Per far ripartire il Pickit 3 dovevo cliccare il pulsante mentre collegavo alla usb e tornava a funzionare ovviamente solo con l'MPLAB vecchio.

Ho provato ad aggiornare il firmware ecc ma nulla.

Dopo l'ennesimo blocco (ho buttato il MPLABX giù, scollato il Pickit 3 dalla usb) quando ricollego il pickit 3 alla usb sia con pulsante premuto che non alla fine ottengo sempre tutti e tre i led accesi con il led di status rosso.

Adesso il pickit 3 non viene riconosciuto più neanche dall'MPLAB vecchio...

sarà definitivamente partito? c'è modo di ripristinarlo? ho letto in rete che bisognerebbe riprogrammare il micro con un altro pickit 3 funzionante (che non possiedo).

Help me please

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 8 Mesi fa #2 da Mauro Laurenti
Risposta da Mauro Laurenti al topic Pickit 3 sembra non funzionare più...
Salve Manuel,

questo thread della Microchip fa probabilmente al caso tuo.
Se il PICKIT dovesse essere rotto, ed e' originale Microchip, lo dovrebbero cambiare con uno nuovo.

In ogni modo non tenere MPLAB IDE e X in contemporanea.
Se programmi con i due ambienti ogni volta rischi che il programmatore debba essere riprogrammato perche' la versione del firmware non e' corretto.

Saluti,

Mauro
Ringraziano per il messaggio: manuelfantoni

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • manuelfantoni
  • Offline
  • New Member
  • New Member
Di più
5 Anni 8 Mesi fa #3 da manuelfantoni
Risposta da manuelfantoni al topic Pickit 3 sembra non funzionare più...
Grazie per la risposta.

Il pickit 3 sembrava irrecuperabile perchè dopo tanti tentativi la situazione non si sbloccava e tutti e tre i led restavano accesi con status rosso.
Il giorno dopo riprovando si è "miracolosamente sbloccato", dopo questo ho iniziato a fare tentativi usando altri pc in mio possesso ed ho la situazione seguente:

ASUS con i7 Windows 10 64 bit > funziona l' MPLAB ma non l'MPLAB X
Dell i5 Windows 7 64 bit > non funziona l'MPLAB x (l'MPLAB non l'ho neanche installato)
Netbook ACER processore Atom Windows 7 a 32 bit > MPLAB X FUNZIONA!!! (molto lento...)

La cosa ridicola è che quando ho installato l'MPLAB X sul Netbook mi è uscita una pop-up di alert in cui mi si diceva che su 32 bit non era consigliato installare l'MPLAB X... ma alla fine è l'unico mio pc su cui gira!!!

Sui vari PC ho provato di tutto, ho letto tutti i forum ma non c'è stato verso.

credo che sia un problema di driver USB ma possibile che succede solo a me?

per adesso proverò ad usarlo con il netbook l'MPLAB normale mi sembra troppo arcaico...

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 8 Mesi fa #4 da Mauro Laurenti
Risposta da Mauro Laurenti al topic Pickit 3 sembra non funzionare più...
Unica cosa che potrebbe creare problemi è la versione di java che hai installato.
Controlla che sia la stessa e l'ultima.
Personalmente ho usato il PICKIT 3 su diversi PC e sistemi operativi senza avere problemi.
Ormai da diversi anni uso MPLAB X.

Saluti,

Mauro

Si prega Accedi o Crea un account a partecipare alla conversazione.

Moderatori: Mauro Laurenti