Progetti

   

Tutorial

   

Servizi

   

Sponsor  

   
Benvenuto, Ospite
Nome utente: Password: Ricordami
  • Pagina:
  • 1
  • 2
  • 3

ARGOMENTO: Sensori ultrasuoni

Sensori ultrasuoni 6 Anni 2 Mesi fa #1

  • mauri
  • Avatar di mauri
  • Offline
  • Fresh Boarder
  • Messaggi: 15
  • Karma: 0
Salve a tutti del forum.
Avrei una domanda da porvi. Ho fatto un sistema per monitorare il liquido da una cisterna per una casa in campagna, usando un sensore ad ultrasuoni.
Pensavo di usare la misura rilevata dal sensore e sottrarla dalla misura fissa dell'altezza della cisterna. Così facendo trovavo il livello del liquido presente nella cisterna.
Il circuito l'ho realizzato usando il sensore SRF02 in configurazione seriale, usado due MAX232 (il sensore e il visualizzatore sono a circa 4 metri di distanza uno dall'altro) trasmetto e ricevo i dati dal sensore al microcontrollore (PIC) che fà anche da interfaccia a un display LCD 16X2. Il progetto sembra che funziona regolarmente.
L'unico problema è quando legge i dati e fà la sottrazione della misura del contenitore, la prima misura è abbastanza giusta (sbaglia di 1 - 2 centimetri dalla misura effettiva, misura verificata con un metro lineare) poi mi legge una misura casuale come se il serbatoio sia pieno quando non lo è.
Voi sapete se magari il liquido non trasmette regolarmente il segnale di ritorno dell'eco del sensore?
Da una misura all'altra ho messo un ciclo di ritardo di circa 1 secondo per avere la certezza che una rilevazione non sia influenzata dalla precedente.
Resto in attesa di una vostra risposta in merito e ringrazio.

Maurizio.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Sensori ultrasuoni 6 Anni 2 Mesi fa #2

  • alfa75
  • Avatar di alfa75
  • Offline
  • Platinum Boarder
  • Messaggi: 527
  • Ringraziamenti ricevuti 86
  • Karma: 7
Ciao mauri

sei sicuro che non ci siano errori nel software?
se hai la possibilità fai una prova
posiziona sull' acqua un coperchio di plastica o qualcosa di simile tipo galleggiante è fai in modo che il sensore punti li sopra è non direttamente sull'acqua se la cosa migliora allora può dipendere dall eco dell'acqua altrimenti è il software

Saluti
Andrea
Ultima modifica: 6 Anni 2 Mesi fa da alfa75.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Sensori ultrasuoni 6 Anni 2 Mesi fa #3

  • Cosimix
  • Avatar di Cosimix
  • Offline
  • Gold Boarder
  • Messaggi: 198
  • Ringraziamenti ricevuti 26
  • Karma: 3
Salve!

Prova ad utilizzare tutto il sistema in campo aperto. Prova (ad esempio) a misurare la distanza di una parete. Se non funziona regolarmente, allora ci sono problemi software.
E' probabile, però, che le misure anomale dipendano dal fatto che la cisterna è un ambiente chiuso. Indipendentemente dall'intensità dell'eco a seguito del contatto dell'onda con il liquido, il sensore potrebbe ricevere i segnali di ritorno dei burst delle misure precedenti a causa delle riflessioni multiple.

Saluti,
Cosimo
Ultima modifica: 6 Anni 2 Mesi fa da Cosimix.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Sensori ultrasuoni 6 Anni 2 Mesi fa #4

  • mauri
  • Avatar di mauri
  • Offline
  • Fresh Boarder
  • Messaggi: 15
  • Karma: 0
Grazie per le informazioni.
Per Alfa75,
non riesco a mettere una sagoma di plastica o comunque di solido nella cisterna, ha il foro troppo piccolo circa 8 centimetri, percui il pezzo deve essere più piccolo di questa misura e comunque riuscire a posizionare con precisione il galleggiante è una cosa impossibile.
Per Cosimix,
ho provato a togliere il sensore dalla cisterna e farlo puntare verso il plafone di copertura della cisterna, così la misura è più stabile. Pensavo anch'io a problemi di riflessione del burst, per questo motivo ho messo un ritardo di 1 secondo ma credo che questo non sia sufficiente. Ho anche fatto un cono di legno per concentrare il segnale acustico, ma anche con questo artificio la situazione non migliora.
Proverò quindi a modificare il software mettendo qualche ritardo ancora e magari facendo una media sulle letture così da stabilizzare il tutto.
Inavvertitamente ho cancellato il sorgente del programma percui devo ricominciare tutto da capo.

Maurizio.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

Sensori ultrasuoni 6 Anni 2 Mesi fa #5

  • alfa75
  • Avatar di alfa75
  • Offline
  • Platinum Boarder
  • Messaggi: 527
  • Ringraziamenti ricevuti 86
  • Karma: 7
Ciao
Maurizio

quindi il problema è l'eco creato dall'acqua
prova a infilare la capsula dentro un pezzo di tubo in pvc o simili ,ma non farlo troppo lungo altrimenti l'eco creato dalle pareti del tubo falserà la misura, devi andare un pò a tentativi è vedere se ci sono miglioramenti
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
  • Pagina:
  • 1
  • 2
  • 3
Powered by Forum Kunena
   
© LaurTec 2006-2015